blox

   

HomeBLOX Support

Get help with installing and configuring Blox SBC

Freeblox UI install error Messages in this topic - RSS

dswindon
dswindon
Posts: 2


12/1/2017
dswindon
dswindon
Posts: 2
Hi All

I am trying to get going, I installed the ISO for BLOX. Configured the Internal and External IP address on each network card.
Ping works fine so I am comfortable that the install worked.

Then I install the FreeBlox UI interface, and it start and then seems to die, this is what is reported on the screen.

<--------Snip-------->

[root@localhost freeblox]# rpm -ivh freeblox-1.0.5-2.x86_64.rpm
warning: freeblox-1.0.5-2.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 85554669: NOKEY
Preparing... ########################################### [100%]
Package pre running.. 1
1:freeblox ########################################### [100%]
Package post running.. 1
`/etc/freeblox_conf/DB/freeblox.db.default' -> `/var/tmp/freeblox.db.default.2009'
`/etc/freeblox_conf/DB/freeblox.db' -> `/var/tmp/freeblox.db.default.2009'
Error: near line 1: no such table: MEDIA_PORT_SETTINGS
MEDIA_PORT_SETTINGS have empty
Error: near line 2: no such table: MEDIA_PORT_SETTINGS
/usr/bin/updatehost BloXeSBC;
echo -n $(grep -w Port /etc/ssh/sshd_config | awk '{print $2}')
22


cp /etc/ssh/sshd_config_default /etc/ssh/sshd_config
sed -i.bak 's/port_val/ 22 /g' /etc/ssh/sshd_config
/etc/init.d/sshd stop; /etc/init.d/sshd start;chkconfig sshd on
Stopping sshd: [ OK ]
Starting sshd: [ OK ]
iptables -R INPUT_ACCESS_RULES 1 -p tcp --dport 22 -j DROP
iptables -R INPUT_ACCESS_RULES 1 -p tcp --dport 22 -j INPUT_FILTER
iptables-save > /etc/sysconfig/iptables
mv /etc/sysconfig/network-scripts//ifcfg-lo /tmp/
cd /etc/sysconfig/network-scripts/ && for iface in $(ls ifcfg-*|sed 's/^ifcfg-//'|sed 's/.cfg$//'); do ifdown $iface ;ip addr flush dev $iface; done
Device "External" does not exist.
<--------Snip End -------->

When it get to this point the Network interfaces become unavailable. My Putty looses connection.

I reinstalled twice from scratch to ensure it was not an ID10T error.

Looks like it is looking for something, I have not clue what to do.

Thanks for guidance please. BLOX was the version from the blox.org ISO (ISO Blox 1.0.4-8), was going to patch via the UI once that was up and running.
edited by dswindon on 12/1/2017
0 link
bloxsupport1
bloxsupport1
Posts: 170


12/3/2017
bloxsupport1
bloxsupport1
Posts: 170
Hi,


Please check the version of Blox Installed by giving command


rpm -qa | grep blox
If the blox version is 1.0.4-8.x86_64 and freeblox version is freeblox-1.0.5-2.x86_64.rpm,

You need to upgrade your Blox machine to 1.0.5-2 version.


If you find the two freeblox version installed, kindly remove both version and install the latest version,
Command to remove the
freeblox rpm -e [freeblox version>]


Command to Install latest version
rpm -ivh [freeblox latest version>]
or
Command to upgrade latest version

rpm -Uvh [freeblox latest version]

Please assign the IP manually to blox using ifconfig, then login into GUI. In Dashboard, Click on the Refresh button in Network Status filed.
Then goto the Network -- Setting, and configure your network profiles.


Thanks
edited by varadhan on 12/3/2017
edited by varadhan on 12/3/2017
0 link
dswindon
dswindon
Posts: 2


12/3/2017
dswindon
dswindon
Posts: 2
Thanks for you feedback.

I am not an expert in Linux so find my way around referring to articles on google and from the Blox and FreeBlox sites.

I have not found a command after downloading the patch for blox from 1.0.4-8.x86_64 to 1.0.5-2 on how to apply it.
I downloaded the update and I am not sure how to "trigger" the patch before installing the new FreeBloX you mention above.

Perhaps you can assist with this simple command which will then push me forward.

Thanks in anticipation.
0 link
bloxsupport1
bloxsupport1
Posts: 170


12/3/2017
bloxsupport1
bloxsupport1
Posts: 170
please contact us via skype: blox.support, we will guide you
0 link
jteitel
jteitel
Posts: 2


12/7/2017
jteitel
jteitel
Posts: 2
I am having the same problem. And I get an error when trying to assign IP address manually using ifconfig. See attached screenshot.


Jeff Teitel
jeff@teitel.net

Attachments:
blox.png
0 link
bloxsupport1
bloxsupport1
Posts: 170


12/7/2017
bloxsupport1
bloxsupport1
Posts: 170
Hi,

Try with the command ifconfig eth0 [IPADDRESS] netmask [netmask]



jteitel wrote:
I am having the same problem. And I get an error when trying to assign IP address manually using ifconfig. See attached screenshot.


Jeff Teitel
jeff@teitel.net
0 link
jteitel
jteitel
Posts: 2


12/8/2017
jteitel
jteitel
Posts: 2
That did it. Thanks!

Jeff

bloxsupport1 wrote:
Hi,

Try with the command ifconfig eth0 [IPADDRESS] netmask [netmask]
0 link
markb
markb
Posts: 1


12/17/2017
markb
markb
Posts: 1
Hi All,
I've been wrestling with this problem ..interfaces config just disappearing when freeblox rpm is installed. Doing ifconfig eth0 and giving it an IP/mask allows me to get to the GUI but the interfaces were not appearing in network status. Updating blox didn't resolve the problem. After a lot of trial and error I've got a solution.

Firstly if you're building this VM in hyper-V you must install "legacy network adapters" NICs in my case I setup three, after the initialize they appear as eth0,eth1 and eth2.

I made a backup of ifcfg-ethX files then copied them back


mkdir /etc/sysconfig/network-scripts/backup
cp /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/backup/ifcfg-eth0

cp /etc/sysconfig/network-scripts/backup/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0


Now I refresh network status and the ethX NICs are there.
Thanks,
MB
0 link
CKO
CKO
Posts: 5


12/18/2017
CKO
CKO
Posts: 5
If you are using Blox ISO as an install, try using "system-config-network" command without arguments to manage the interfaces. For me it works just fine.
edited by CKO on 12/18/2017
0 link
quan.pt
quan.pt
Posts: 7


1/17/2018
quan.pt
quan.pt
Posts: 7
CKO wrote:
If you are using Blox ISO as an install, try using "system-config-network" command without arguments to manage the interfaces. For me it works just fine.
edited by CKO on 12/18/2017

Thank you so much CKO ! When I use your command I didn't got this error.
0 link






Powered by blox.org 1.0.0.0 © 2015